Fork me on GitHub

Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 47
Number of unique artifacts (NOA): 53
Number of version-conflicting artifacts (NOC): 3
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 88 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

org.codehaus.plexus:plexus-classworlds

[Error]
2.5.1
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.codehaus.plexus:plexus-classworlds:jar:2.5.1:provided

2.5.2
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.codehaus.plexus:plexus-classworlds:jar:2.5.2:provided

org.codehaus.plexus:plexus-utils

[Error]
1.0.4
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:provided
             \- org.codehaus.plexus:plexus-utils:jar:1.0.4:provided

1.5.5
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- org.codehaus.plexus:plexus-utils:jar:1.5.5:provided

2.1
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.codehaus.plexus:plexus-utils:jar:2.1:provided

3.0.20
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       +- org.apache.maven:maven-model:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-settings:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-settings-builder:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-repository-metadata:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-artifact:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-model-builder:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
       |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
       \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided

3.5.1
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven.enforcer:enforcer-api:jar:3.3.0:provided
       \- org.codehaus.plexus:plexus-utils:jar:3.5.1:provided

org.sonatype.sisu:sisu-guice

[Error]
3.1.6
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.6:provided

3.2.3
    org.codehaus.mojo:extra-enforcer-rules:jar:1.7.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.sisu:sisu-guice:jar:no_aop:3.2.3:provided