Fork me on GitHub

Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 18
Number of unique artifacts (NOA): 22
Number of version-conflicting artifacts (NOC): 2
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): error 81 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.

Dependencies used in this project

org.apache.maven:maven-artifact

error
2.2.1
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
       |  \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
       \- org.apache.maven:maven-artifact:jar:2.2.1:compile

3.0
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.4:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 2.2.1)

org.codehaus.plexus:plexus-utils

error
1.0.4
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict with 1.5.15)

1.4.2
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
          \- org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-6:compile
             \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict with 1.5.15)

1.5.15
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    +- org.apache.maven:maven-model:jar:2.2.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.22)
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       +- org.apache.maven:maven-settings:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-profile:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
       |  +- org.apache.maven:maven-repository-metadata:jar:2.2.1:compile
       |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-plugin-registry:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       +- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       \- org.apache.maven:maven-artifact:jar:2.2.1:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)

3.0.22
    org.codehaus.mojo:properties-maven-plugin:maven-plugin:1.0.0
    \- org.codehaus.plexus:plexus-utils:jar:3.0.22:compile