Fork me on GitHub

Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 53
Number of unique artifacts (NOA): 59
Number of version-conflicting artifacts (NOC): 6
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 89 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

javax.annotation:javax.annotation-api

[Error]
1.2
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
          \- javax.annotation:javax.annotation-api:jar:1.2:runtime

1.2-b03
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- javax.xml.ws:jaxws-api:jar:2.2.11:runtime
          \- (javax.annotation:javax.annotation-api:jar:1.2-b03:runtime - omitted for conflict with 1.2)

javax.xml.bind:jaxb-api

[Error]
2.2.12-b140109.1041
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       +- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
       |  \- (javax.xml.bind:jaxb-api:jar:2.2.12-b140109.1041:runtime - omitted for duplicate)
       \- javax.xml.bind:jaxb-api:jar:2.2.12-b140109.1041:runtime

2.2.9
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- javax.xml.ws:jaxws-api:jar:2.2.11:runtime
          \- (javax.xml.bind:jaxb-api:jar:2.2.9:runtime - omitted for conflict with 2.2.12-b140109.1041)

javax.xml.soap:javax.xml.soap-api

[Error]
1.3.5
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       +- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
       |  \- com.sun.xml.messaging.saaj:saaj-impl:jar:1.3.25:runtime
       |     \- (javax.xml.soap:javax.xml.soap-api:jar:1.3.5:runtime - omitted for conflict with 1.3.7)
       \- javax.xml.ws:jaxws-api:jar:2.2.11:runtime
          \- (javax.xml.soap:javax.xml.soap-api:jar:1.3.5:runtime - omitted for conflict with 1.3.7)

1.3.7
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       +- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
       |  \- (javax.xml.soap:javax.xml.soap-api:jar:1.3.7:runtime - omitted for duplicate)
       \- javax.xml.soap:javax.xml.soap-api:jar:1.3.7:runtime

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.4
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- org.apache.maven:maven-plugin-api:jar:3.0:compile
       \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.4:compile - omitted for conflict with 1.5.5)

1.5.5
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- org.apache.maven:maven-core:jar:3.0:compile
       +- org.apache.maven:maven-settings-builder:jar:3.0:compile
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile - omitted for conflict with 1.5.4)
       +- org.apache.maven:maven-model-builder:jar:3.0:compile
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile - omitted for conflict with 1.5.4)
       +- org.apache.maven:maven-aether-provider:jar:3.0:runtime
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:runtime - omitted for conflict with 1.5.4)
       \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile

org.jvnet.mimepull:mimepull

[Error]
1.9
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
          \- com.sun.xml.messaging.saaj:saaj-impl:jar:1.3.25:runtime
             \- (org.jvnet.mimepull:mimepull:jar:1.9:runtime - omitted for conflict with 1.9.4)

1.9.4
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
          \- org.jvnet.mimepull:mimepull:jar:1.9.4:runtime

org.jvnet.staxex:stax-ex

[Error]
1.7.1
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
          \- com.sun.xml.stream.buffer:streambuffer:jar:1.5.3:runtime
             \- (org.jvnet.staxex:stax-ex:jar:1.7.1:runtime - omitted for conflict with 1.7.7)

1.7.7
    org.codehaus.mojo:jaxws-maven-plugin:maven-plugin:2.5
    \- com.sun.xml.ws:jaxws-tools:jar:2.2.10:runtime
       \- com.sun.xml.ws:jaxws-rt:jar:2.2.10:runtime
          +- org.jvnet.staxex:stax-ex:jar:1.7.7:runtime
          \- com.sun.xml.messaging.saaj:saaj-impl:jar:1.3.25:runtime
             \- (org.jvnet.staxex:stax-ex:jar:1.7.7:runtime - omitted for duplicate)