Fork me on GitHub

Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 56
Number of unique artifacts (NOA): 79
Number of version-conflicting artifacts (NOC): 11
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 70 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

com.google.code.findbugs:jsr305

[Error]
3.0.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.apache.maven.shared:maven-shared-utils:jar:3.1.0:compile
             \- com.google.code.findbugs:jsr305:jar:3.0.0:provided

3.0.2
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.assertj:assertj-core:jar:3.23.1:test
       \- net.bytebuddy:byte-buddy:jar:1.12.10:test
          \- com.google.code.findbugs:jsr305:jar:3.0.2:provided

org.apache.maven:maven-artifact

[Error]
3.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       +- org.apache.maven:maven-artifact:jar:3.0:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.apache.maven:maven-artifact:jar:3.0:compile

3.2.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven:maven-artifact:jar:3.2.5:provided
    +- org.apache.maven:maven-core:jar:3.2.5:provided
    |  \- org.apache.maven:maven-artifact:jar:3.2.5:provided
    +- org.apache.maven:maven-plugin-api:jar:3.2.5:provided
    |  \- org.apache.maven:maven-artifact:jar:3.2.5:provided
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.apache.maven:maven-artifact:jar:3.2.5:test

org.apache.maven:maven-core

[Error]
3.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       +- org.apache.maven:maven-core:jar:3.0:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.apache.maven:maven-core:jar:3.0:compile

3.0.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-dependency-tree:jar:3.1.1:compile
       \- org.apache.maven:maven-core:jar:3.0.5:compile

3.2.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven:maven-core:jar:3.2.5:provided
    +- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
    |  \- org.apache.maven:maven-core:jar:3.2.5:test
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.apache.maven:maven-core:jar:3.2.5:test

org.apache.maven:maven-model

[Error]
3.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.apache.maven:maven-model:jar:3.0:compile

3.2.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven:maven-core:jar:3.2.5:provided
    |  +- org.apache.maven:maven-model:jar:3.2.5:provided
    |  \- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
    |     \- org.apache.maven:maven-model:jar:3.2.5:provided
    +- org.apache.maven:maven-model:jar:3.2.5:provided
    +- org.apache.maven:maven-plugin-api:jar:3.2.5:provided
    |  \- org.apache.maven:maven-model:jar:3.2.5:provided
    +- org.apache.maven:maven-model-builder:jar:3.2.5:provided
    |  \- org.apache.maven:maven-model:jar:3.2.5:provided
    +- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
    |  \- org.apache.maven:maven-model:jar:3.2.5:test
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.apache.maven:maven-model:jar:3.2.5:test

org.codehaus.plexus:plexus-classworlds

[Error]
2.2.3
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
             \- org.codehaus.plexus:plexus-classworlds:jar:2.2.3:compile

2.5.1
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.codehaus.plexus:plexus-classworlds:jar:2.5.1:provided

2.5.2
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.codehaus.plexus:plexus-classworlds:jar:2.5.2:compile

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.4
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
             \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.4:compile

1.5.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven:maven-core:jar:3.2.5:provided
    |  +- org.apache.maven:maven-settings-builder:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided
    |  +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided
    |  +- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
    |  |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided
    |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile
    +- org.apache.maven:maven-model-builder:jar:3.2.5:provided
    |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test

2.0.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.codehaus.plexus:plexus-component-annotations:jar:2.0.0:compile

org.codehaus.plexus:plexus-utils

[Error]
1.0.4
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:provided
             \- org.codehaus.plexus:plexus-utils:jar:1.0.4:provided

1.5.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- org.codehaus.plexus:plexus-utils:jar:1.5.5:provided

2.0.5
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
             \- org.codehaus.plexus:plexus-utils:jar:2.0.5:compile

2.1
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.codehaus.plexus:plexus-utils:jar:2.1:provided

3.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-io:jar:2.0.4:test
             \- org.codehaus.plexus:plexus-utils:jar:3.0:test

3.0.15
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
    |  \- org.codehaus.plexus:plexus-utils:jar:3.0.15:test
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.apache.maven.wagon:wagon-provider-api:jar:2.8:test
          \- org.codehaus.plexus:plexus-utils:jar:3.0.15:test

3.0.20
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    +- org.apache.maven:maven-artifact:jar:3.2.5:provided
    |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    +- org.apache.maven:maven-core:jar:3.2.5:provided
    |  +- org.apache.maven:maven-settings:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    |  +- org.apache.maven:maven-settings-builder:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    |  +- org.apache.maven:maven-repository-metadata:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    |  +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
    |  |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    +- org.apache.maven:maven-model:jar:3.2.5:provided
    |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    +- org.apache.maven:maven-model-builder:jar:3.2.5:provided
    |  \- org.codehaus.plexus:plexus-utils:jar:3.0.20:provided
    \- org.apache.maven:maven-compat:jar:3.2.5:test
       \- org.codehaus.plexus:plexus-utils:jar:3.0.20:test

3.0.7
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-utils:jar:3.0.7:test

3.3.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.codehaus.plexus:plexus-utils:jar:3.3.0:compile

3.4.2
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.codehaus.plexus:plexus-utils:jar:3.4.2:compile

org.eclipse.aether:aether-api

[Error]
0.9.0.M2
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.eclipse.aether:aether-api:jar:0.9.0.M2:provided

1.0.0.v20140518
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
       |  +- org.eclipse.aether:aether-api:jar:1.0.0.v20140518:provided
       |  \- org.eclipse.aether:aether-spi:jar:1.0.0.v20140518:provided
       |     \- org.eclipse.aether:aether-api:jar:1.0.0.v20140518:provided
       +- org.eclipse.aether:aether-impl:jar:1.0.0.v20140518:provided
       |  \- org.eclipse.aether:aether-api:jar:1.0.0.v20140518:provided
       +- org.eclipse.aether:aether-api:jar:1.0.0.v20140518:compile
       \- org.eclipse.aether:aether-util:jar:1.0.0.v20140518:compile
          \- org.eclipse.aether:aether-api:jar:1.0.0.v20140518:compile

org.eclipse.aether:aether-impl

[Error]
0.9.0.M2
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.eclipse.aether:aether-impl:jar:0.9.0.M2:provided

1.0.0.v20140518
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
       |  \- org.eclipse.aether:aether-impl:jar:1.0.0.v20140518:provided
       \- org.eclipse.aether:aether-impl:jar:1.0.0.v20140518:provided

org.eclipse.aether:aether-util

[Error]
1.0.0.v20140518
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       +- org.apache.maven:maven-aether-provider:jar:3.2.5:provided
       |  \- org.eclipse.aether:aether-util:jar:1.0.0.v20140518:provided
       +- org.eclipse.aether:aether-impl:jar:1.0.0.v20140518:provided
       |  \- org.eclipse.aether:aether-util:jar:1.0.0.v20140518:provided
       \- org.eclipse.aether:aether-util:jar:1.0.0.v20140518:compile

1.1.0
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-dependency-tree:jar:3.1.1:compile
       \- org.eclipse.aether:aether-util:jar:1.1.0:compile

org.sonatype.sisu:sisu-guice

[Error]
2.1.7
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven.shared:maven-artifact-transfer:jar:0.13.1:compile
       \- org.apache.maven.shared:maven-common-artifact-filters:jar:3.1.0:compile
          \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
             \- org.sonatype.sisu:sisu-inject-bean:jar:1.4.2:compile
                \- org.sonatype.sisu:sisu-guice:jar:noaop:2.1.7:compile

3.1.6
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.0.M1:provided
          \- org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.6:provided

3.2.3
    org.codehaus.mojo:flatten-maven-plugin:maven-plugin:1.3.0
    \- org.apache.maven:maven-core:jar:3.2.5:provided
       \- org.sonatype.sisu:sisu-guice:jar:no_aop:3.2.3:provided