Fork me on GitHub

Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 54
Number of unique artifacts (NOA): 69
Number of version-conflicting artifacts (NOC): 10
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 78 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

classworlds:classworlds

[Error]
1.1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- classworlds:classworlds:jar:1.1:compile

1.1-alpha-2
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-project:jar:2.2.1:compile
    |  \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
    |     \- (classworlds:classworlds:jar:1.1-alpha-2:compile - omitted for conflict with 1.1)
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:compile
          \- (classworlds:classworlds:jar:1.1-alpha-2:compile - omitted for conflict with 1.1)

org.apache.maven:maven-artifact

[Error]
2.2.1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-toolchain:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
    +- org.apache.maven:maven-project:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact:jar:2.2.1:compile
    +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       +- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
       \- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
          \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)

3.0
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.4:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 2.2.1)

org.apache.maven:maven-core

[Error]
2.0
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:test
       \- (org.apache.maven:maven-core:jar:2.0:test - omitted for conflict with 2.2.1)

2.2.1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-toolchain:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-core:jar:2.2.1:compile - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:2.2.1:compile

org.apache.maven:maven-plugin-api

[Error]
2.2.1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-plugin-api:jar:2.2.1:compile

3.0
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       +- (org.apache.maven:maven-plugin-api:jar:3.0:compile - version managed from 2.2.1; omitted for conflict with 2.2.1)
       \- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
          \- (org.apache.maven:maven-plugin-api:jar:3.0:compile - version managed from 2.2.1; omitted for duplicate)

org.apache.maven:maven-project

[Error]
2.0
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:test
       \- (org.apache.maven:maven-project:jar:2.0:test - omitted for conflict with 2.2.1)

2.2.1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-project:jar:2.2.1:compile
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- (org.apache.maven:maven-project:jar:2.2.1:compile - omitted for duplicate)

org.codehaus.plexus:plexus-container-default

[Error]
1.0-alpha-30
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.apache.maven.reporting:maven-reporting-api:jar:2.2.1:compile
          \- org.apache.maven.doxia:doxia-logging-api:jar:1.1:compile
             \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile - omitted for conflict with 1.0-alpha-9-stable-1)

1.0-alpha-8
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:1.0-alpha-7:test
          \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-8:test - omitted for conflict with 1.0-alpha-9-stable-1)

1.0-alpha-9-stable-1
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-project:jar:2.2.1:compile
    |  +- org.apache.maven:maven-settings:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-profile:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-plugin-registry:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
    |  \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
    +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
    |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       +- org.apache.maven:maven-plugin-parameter-documenter:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
       +- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
       +- org.apache.maven:maven-error-diagnostics:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)
       \- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
          \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for duplicate)

org.codehaus.plexus:plexus-interactivity-api

[Error]
1.0-alpha-4
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:compile

1.0-alpha-6
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-6:compile
          \- org.apache.maven.wagon:wagon-ssh-common:jar:1.0-beta-6:compile
             \- (org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-6:compile - omitted for conflict with 1.0-alpha-4)

org.codehaus.plexus:plexus-interpolation

[Error]
1.11
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       +- org.apache.maven:maven-settings:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.11:compile - omitted for duplicate)
       +- org.apache.maven:maven-profile:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.11:compile - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-interpolation:jar:1.11:compile - omitted for conflict with 1.21)

1.21
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.codehaus.plexus:plexus-interpolation:jar:1.21:test (scope not updated to compile)

org.codehaus.plexus:plexus-utils

[Error]
1.0.4
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict with 1.5.15)

1.2
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:1.0-alpha-7:test
          \- (org.codehaus.plexus:plexus-utils:jar:1.2:test - omitted for conflict with 3.0.20)

1.4.2
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
    |  \- org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-6:compile
    |     \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict with 1.5.15)
    +- org.apache.maven:maven-core:jar:2.2.1:compile
    |  +- org.apache.maven.wagon:wagon-ssh-external:jar:1.0-beta-6:runtime
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:runtime - omitted for conflict with 1.5.15)
    |  \- org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-6:compile
    |     +- (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict with 1.5.15)
    |     \- org.apache.maven.wagon:wagon-ssh-common:jar:1.0-beta-6:compile
    |        \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict with 1.5.15)
    \- org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:test
       \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:test - omitted for conflict with 3.0.20)

1.5.15
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    +- org.apache.maven:maven-project:jar:2.2.1:compile
    |  +- org.apache.maven:maven-settings:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-profile:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-plugin-registry:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.20)
    +- org.apache.maven:maven-model:jar:2.2.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact:jar:2.2.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
    |  +- org.apache.maven:maven-repository-metadata:jar:2.2.1:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       +- org.apache.maven:maven-plugin-parameter-documenter:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for duplicate)

1.5.5
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 1.5.15)

3.0.20
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.codehaus.plexus:plexus-utils:jar:3.0.20:compile

org.slf4j:slf4j-api

[Error]
1.5.3
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.apache.maven.wagon:wagon-webdav-jackrabbit:jar:1.0-beta-6:runtime
          +- org.apache.jackrabbit:jackrabbit-webdav:jar:1.5.0:runtime
          |  \- (org.slf4j:slf4j-api:jar:1.5.3:runtime - omitted for conflict with 1.5.6)
          \- org.slf4j:slf4j-nop:jar:1.5.3:runtime
             \- (org.slf4j:slf4j-api:jar:1.5.3:runtime - omitted for duplicate)

1.5.6
    org.codehaus.mojo:exec-maven-plugin:maven-plugin:1.6.0
    \- org.apache.maven:maven-core:jar:2.2.1:compile
       \- org.slf4j:slf4j-jdk14:jar:1.5.6:runtime
          \- org.slf4j:slf4j-api:jar:1.5.6:runtime